Welcome, Guest
You have to register before you can post on our site.

Username/Email:
  

Password
  





Search Forums

(Advanced Search)

Forum Statistics
» Members: 405
» Latest member: bradashtolzey3704
» Forum threads: 30
» Forum posts: 81

Full Statistics

Online Users
There are currently 21 online users.
» 0 Member(s) | 21 Guest(s)

Latest Threads
ecotag with custom refere...
Forum: Using OBITools
Last Post: celine.mercier
09-14-2017, 02:49 PM
» Replies: 1
» Views: 211
Error running obiconvert
Forum: Using OBITools
Last Post: laur34
11-01-2016, 08:18 PM
» Replies: 3
» Views: 5,250
Problem with building the...
Forum: Using OBITools
Last Post: Robert
10-11-2016, 09:46 AM
» Replies: 3
» Views: 4,689
abiannotate: how to acces...
Forum: Using OBITools
Last Post: coissac
08-11-2016, 04:39 AM
» Replies: 1
» Views: 2,619
Database
Forum: Using OBITools
Last Post: adejode
08-08-2016, 02:50 PM
» Replies: 0
» Views: 1,567
obiextract: bug?
Forum: Using OBITools
Last Post: cbird
08-05-2016, 12:16 AM
» Replies: 2
» Views: 2,186
Parallel Strategies
Forum: Using OBITools
Last Post: cbird
08-01-2016, 03:11 PM
» Replies: 1
» Views: 1,896
ngsfilter: pattern matchi...
Forum: Using OBITools
Last Post: cbird
08-01-2016, 02:53 PM
» Replies: 4
» Views: 2,842
illuminapairedend: align...
Forum: Using OBITools
Last Post: cbird
08-01-2016, 02:41 PM
» Replies: 2
» Views: 2,350
ngsfilter: error arg / fu...
Forum: Using OBITools
Last Post: coissac
07-23-2016, 03:45 PM
» Replies: 1
» Views: 1,854

 
  ecoPCR issue
Posted by: antonino.malacrino - 03-08-2016, 03:41 PM - Forum: Using OBITools - Replies (1)

Hello!
I tried to figure out this problem, but I didn't succeeded.

When I use this command:


> ./ecoPCR -d /files -e 3 -l 50 -L 1500  AAGCTCGTAGTTGAATTTCG CCCAACTATCCCTATTAATCAT

I get this result:

#@ecopcr-v2
#
# ecoPCR version 0.2
# direct  strand oligo1 : AAGCTCGTAGTTGAATTTCG             ; oligo2c :           ATGATTAATAGGGATAGTTGGG
# reverse strand oligo2 : CCCAACTATCCCTATTAATCAT           ; oligo1c :             CGAAATTCAACTACGAGCTT
# max error count by oligonucleotide : 3
# optimal Tm for primers 1 : 53.16
# optimal Tm for primers 2 : 51.06
# database : /files
# amplifiat length between [50,1500] bp
# output in superkingdom mode
# DB sequences are considered as linear
#
Error 1 in file ecoIOUtils.c line 101 : Cannot open file
Abort trap: 6

Can someone help me?

Print this item

  Problems installing ecoPCR and ecoPRIMERS
Posted by: JHarrison - 03-04-2016, 05:35 AM - Forum: Installing OBITools - Replies (3)

Hi,

I'm having a problem installing ecoPCR and ecoPrimers. I can use OBITools fine, but when trying to run the ecoPCR make file It returns the following :

global.mk:18: ecopcr.P: No such file or directory
global.mk:18: ecofind.P: No such file or directory
global.mk:18: ecoisundertaxon.P: No such file or directory
gcc -DMAC_OS_X -M  -o ecoisundertaxon.d ecoisundertaxon.c
gcc -DMAC_OS_X -M  -o ecofind.d ecofind.c
gcc -DMAC_OS_X -M  -o ecopcr.d ecopcr.c
gcc -DMAC_OS_X -W -Wall -O2 -g -c -o ecopcr.o ecopcr.c
ecopcr.c: In function ‘printRepeat’:
ecopcr.c:146:11: warning: variable ‘tm’ set but not used [-Wunused-but-set-variable]
  double   tm=0;
           ^
ecopcr.c: In function ‘main’:
ecopcr.c:513:9: warning: variable ‘tm’ set but not used [-Wunused-but-set-variable]
  double tm,tm1,tm2;
         ^
ecopcr.c:337:16: warning: variable ‘amplifiatCount’ set but not used [-Wunused-but-set-variable]
  int32_t       amplifiatCount  = 0;
                ^
ecopcr.c:336:16: warning: variable ‘positiveSequence’ set but not used [-Wunused-but-set-variable]
  int32_t       positiveSequence= 0;
                ^
ecopcr.c:312:17: warning: variable ‘scname’ set but not used [-Wunused-but-set-variable]
  char          *scname;
                 ^
make -C libapat
make[1]: Entering directory `/home/jori/Documents/ecoPCR/src/libapat'
../global.mk:18: apat_parse.P: No such file or directory
../global.mk:18: apat_search.P: No such file or directory
../global.mk:18: libstki.P: No such file or directory
 

and so on as it goes through all of the subfolders.

I'm on Ubuntu14.04. I don't have a ton of experience with line commands programs or linux; I would really appreciate some help pointing me in the right direction!

Print this item

  Problem working with OBItools/EcoPCR
Posted by: coissac - 02-13-2016, 07:19 PM - Forum: Using OBITools - Replies (2)

We working with Obitools based on the Wolves’ diet protocol and we
really love it. But we have a big problem by download the whole set of
EMBL sequences. It is downloading nothing by using:  wget -nH
--cut-dirs=4 -Arel_std_\*.dat.gz -m
ftp://ftp.ebi.ac.uk/pub/databases/embl/release/ 

We also tried a to download with

wget -nH –cut-dirs=4 -Arel_std_\*.dat.gz -m
ftp://ftp.ebi.ac.uk/pub/databases/ena/sequence/release 
Here we only get a wget-log file, which fails after obiconvert.
Probably by producing empty sdx files and an error in ecoPCR (error 3)
occur. Obviously it is not the write format.

Because of that, we tried also to use NCBI fasta downloads, but there
occurring also errors in obiconvert like:

 File "/opt/anaconda27/bin/obiconvert", line 52, in <module>
   writer(entry)
 File
"/opt/anaconda27/lib/python2.7/site-packages/obitools/format/options.py",
line 371, in sequenceWriter
   writer.put(sequence)
 File
"/opt/anaconda27/lib/python2.7/site-packages/obitools/ecopcr/sequence.py",
line 173, in put
   self._file.write(self._ecoSeqPacker(sequence))
 File
"/opt/anaconda27/lib/python2.7/site-packages/obitools/ecopcr/sequence.py",
line 127, in _ecoSeqPacker
   raise Exception("Taxonomy error for %s: %s"%(seq.id, "taxonomy is
missing" if self._taxonomy is None else "sequence has no taxid" if
'taxid' not in seq else "wrong taxid"))
Exception: Taxonomy error for gi|6066746|emb|AJ012532.1|: sequence has
no taxid

We also tried ecoPCRFormat.py for the same fasta files

ecoPCRFormat.py --fasta --name 18Seco_b --taxonomy ./TAXO
18S_NCBI.fasta

Gives us following files

-rw-r--r--    4  18Seco_b_001.sdx
-rw-r--r--  125429400 18Seco_b.ndx
-rw-r--r--  368  18Seco_b.rdx
-rw-r--r--  64173025 18Seco_b.tdx

ecoPCR -d 18Seco_b -e 3 -l 50 -L 250 \ AGGTCWGTRATGCCCTYMG
TGYACAAAGGBCAGGGAC > 18S_b.ecopcr
à Error 3 in file ecoapat.c line 157 : Error in pattern checking

We are targeting in general Metazoa with 18S and COI from environmental
samples. Sorry for annoying you, but we are a little bit lost. We hope
you can help us for downloading the whole set of sequences and for
formatting them suitable to an ecoPCR database.

Print this item

  Obiconvert issue
Posted by: Aagaard - 02-01-2016, 10:56 AM - Forum: Using OBITools - Replies (1)

Hi everyone

I run into problems running the obiconvert command when trying to convert fasta-files into an ecopcrdb.

I ran the following, which resulted in .sdx .adx .ndx .rdx .tdx files. However, the .sdx file is empy and contains no sequences.
This is what I ran:


$ obiconvert --fasta --taxonomy-dump=/home/taxonomy/ --ecopcrdb-output=obi_db_nor /home/db/trnl_db_norway.fasta
Reading taxonomy dump file...
List all taxonomy rank...
Indexing taxonomy...
Indexing parent and rank...
Adding scientific name...
Adding taxid alias...
Adding deleted taxid...
Writing the taxonomy file... Ok
/home/db/trnl_db_norway.fasta   0.0 % |/      
/home/db/trnl_db_norway.fasta   3.2 % |#-      
/home/db/trnl_db_norway.fasta   3.2 % |#\       
/home/db/trnl_db_norway.fasta   3.2 % |#|       
/home//db/trnl_db_norway.fasta   3.2 % |#/                                                
] remain : 00:00:00Traceback (most recent call last):
  File "/software/src/obitools/OBITools-1.2.2/export/bin/obiconvert", line 52, in <module>
    writer(entry)
  File "/software/src/obitools/OBITools-1.2.2/local/lib/python2.7/site-packages/obitools/format/options.py", line 371, in sequenceWriter
    writer.put(sequence)
  File "/software/src/obitools/OBITools-1.2.2/local/lib/python2.7/site-packages/obitools/ecopcr/sequence.py", line 173, in put
    self._file.write(self._ecoSeqPacker(sequence))
  File "/software/src/obitools/OBITools-1.2.2/local/lib/python2.7/site-packages/obitools/ecopcr/sequence.py", line 127, in _ecoSeqPacker
    raise Exception("Taxonomy error for %s: %s"%(seq.id, "taxonomy is missing" if self._taxonomy is None else "sequence has no taxid" if 'taxid' not in seq else "wrong taxid"))
Exception: Taxonomy error for gi|952951487|gb|KT124270.1|: sequence has no taxid

$ less obi_db_nor_001.sdx
^@^@^@^@


Running the ecopcr afterwards obviosly also returns an error.

Can anyone help?
Am I doing it wrong or is it a bug in obiconvert?

Thanks
/Aagaard

Print this item

  OBIConvert to an ecoPCR database
Posted by: coissac - 01-25-2016, 06:12 PM - Forum: Using OBITools - Replies (1)

Hi, I'm trying to use obitools to test a set of primers on a custom collected sequences.



Basically I want to create a ecopcrdb from a fasta file, but the question is how do I do this?



For example I have a fasta file which looks like:



>380716500
GAAAAAAGGAAACATTTGGTTCTTTAGGAATAATTTATGCTATATTAGCTATTGGTTTACTAGGATTTGTTGTATGAGCTCACCATATATTCACAGTAGGGATAGATGTAGATACACGAGCTTACTTTACTTCAGCAACTATAATTATTGCTGTACCTACTGGAATTAAAATTTTTTCTTGATTAGCAACATTACATGGATCTCAAATTAGATATAGACCTTCATTATTATGAGCTCTAGGATTTGTATTTTTATTTACAGTAGGGGGATTAACTGGAGTAGTATTAGCAAATTCTTCAATTGATATTATTCTACATGATACCTATTATGTAGTTGCACATTTTCATTATGTTTTATCAATAGGGGCAGTATTTGCTATTTTAGCAGGATTTATTCAATGATTCCCATTATTTACCGGATTAACAATAAATTCAAAATTATTAACAATTCAATTTATTGTAATATTTTTTGGAGTAAACTTAACATTCTTCCCACAACATTTTTTAGGGTTAAGAGGTATACCCCGACGTTATTCTGATTATCCTGATG
>768105829
GGAATAATTGGAACAGCCCTAAGTCTTTTAATTCGAGCTGAACTTGGACAACCAGGCTCTCTTTTAGGAGATGATCAGATTTATAATGTAATTGTAACTGCCCACGCTTTCGTAATAATCTTTTTCATAGTTATACCAATTATAATTGGTGGTTTTGGGAATTGGCTCGTGCCTTTAATAATTGGTGCGCCAGATATGGCCTTCCCACGAATAAACAACATAAGCTTTTGGCTTCTTCCACCATCATTCCTTCTCCTCTTAGCTTCCGCTGGGGTAGAAGCTGGAGCAGGTACTGGCTGAACAGTTTACCCTCCATTAGCTAGCAACTTAGCTCATGCTGGACCATCTGTTGACCTAGCTATCTTTTCCCTACACCTAGCCGGTGTATCATCAATCTTAGCCTCAATTAATTTCATTACAACTATTATTAACATGAAACCTCCAGCCATCTCTCAATATCAAACACCATTATTTGTTTGATCCATTCTTGTAACTACTATCCTACTTCTCCTCTCACTTCCAGTTCTCGCAGCAGGAATTACAATATTACTCACAGATCGTAACCTTAATACTACATTCTTTGATCCTGCAGGGGGAGGAGATCCAATCCTTTATCAACACTTATTC




I also have a taxonomy file which looks like:



380716500       k__Eukaryota;p__Arthropoda;c__Insecta;o__Coleoptera;f__Dytiscidae;g__Agabus;s__Agabus_bipustulatus
768105829       k__Eukaryota;p__Chordata;c__Chondrichthyes;o__Carcharhiniformes;f__Carcharhinidae;g__Sphyrna;s_Sphyrna_lewini




Could I possibly make a ecopcrdb from these two files for me to run ecoPCR? Would be much appreciated if you could help.



Many thanks,



Soon





-- 
Dr. Hyun Soon Gweon 

Print this item

  obiconvert
Posted by: Birsch - 09-04-2015, 02:58 PM - Forum: Using OBITools - Replies (4)

Dear Eric,

I managed to go through the whole pipeline using my data and the wolve db from the tutorial and everything worked well now.

But: When trying to create my own DB I ran into an error. Creating a DB using the *.dat files from EMBL works fine. But as one doesn't know which of the *.dat files are of interest, one has to download them all, unpack, obiconvert (which can crash after some hours of running because of errors in one dat-file) etc. and run ecoPCR. As I understand "obiconvert" is able to convert also fasta files and genbank files into ecopcrDB which is nice because it enables to download only sequences from NCBI that match your criteria.

When I used obiconvert on such fasta files as well as genbank files no errors occured, but the following ecoPCR command stopped with this error:

#reading file xxx.sdx containing xx sequences
Segmentation fault (core dumped)

Because obiconvert on EMBL .dat files did not cause this error I guess the problem is caused during conversion using fasta or genbank files.

Probably you know this issue and can help me once more here!

This should be the last thing to solve... Angel 

Thanks a lot,

Birsch

Print this item

  merged_sample
Posted by: Birsch - 09-02-2015, 04:55 PM - Forum: Using OBITools - Replies (2)

Hello Obitool users,

first of all thanks a lot for Obitools!

I was playing around with my data along the lines of the wolve tutorial and I ran into a problem which I was not able to solve so far.

Because I am working on already demutliplexed single end reads I can not use the "ngsfilter" command. But as I understand this script writes the sample information (ID etc.) into the fasta header. When I use "obiuniq -m sample x.fastq > x.uniq.fasta" on my fasta file, I end up with a file with a header that looks like this:


> A1116_1000001 merged_sample={}; count=2164;  HWI-M01108:30:000000000-A7CM1:1:1101:16335:1424 1:N:0:CTCAAGAAGC
agggatataaagcaccgccaagtcctttgagttttaagctgttgctagtagttctctggc
ggatagttttgtttgagttaactatctaggtttagggctaagcatagtggggtatctaat
cccagttt

As I understand I lost the information about which individuals share this sequence!? because according to the tutorial it should look like this:

> HELIUM_000100422_612GNAAXX:7:108:5640:3823#0/1_CONS_SUB_SUB_CMP merged_sample={'29a_F260619': 7, '15a_F730814': 2}; count=9;
aagggtataaagcaccgccaagtcctttgagttttaagctattgccggtagtactctggc
gaacaattttgttatattaattacttgtgtttagggctaa

Is there a way to achieve this outcome with my data? Help is very much appreciated!

Birsch

Print this item

  installation error
Posted by: AselaJ - 08-11-2015, 09:07 PM - Forum: Installing OBITools - Replies (5)

I am having problem installing obitools. 


when I used python get-obitools.py, it gives the following error:




hoekstra10@mcic-ender-svr:~/Working_dir/Ipython-Notebooks/obitool$ python get-obitools.py 
/tmp/tmpj6xtuc/obitools.zip
Downloading/unpacking OBITools
  Downloading OBITools-1.1.22.tar.gz (1.0MB): 1.0MB downloaded
  Saved /tmp/tmpj6xtuc/OBITools-1.1.22.tar.gz
Cleaning up...
Exception:
Traceback (most recent call last):
  File "/tmp/tmpj6xtuc/obitools.zip/pip/basecommand.py", line 122, in main
    status = self.run(options, args)
  File "/tmp/tmpj6xtuc/obitools.zip/pip/commands/install.py", line 278, in run
    requirement_set.prepare_files(finder, force_root_egg_info=self.bundle, bundle=self.bundle)
  File "/tmp/tmpj6xtuc/obitools.zip/pip/req.py", line 1221, in prepare_files
    req_to_install.run_egg_info()
  File "/tmp/tmpj6xtuc/obitools.zip/pip/req.py", line 292, in run_egg_info
    logger.notify('Running setup.py (path:%s) egg_info for package %s' % (self.setup_py, self.name))
  File "/tmp/tmpj6xtuc/obitools.zip/pip/req.py", line 265, in setup_py
    import setuptools
  File "/tmp/tmpj6xtuc/obitools.zip/setuptools/__init__.py", line 11, in <module>
    from setuptools.extension import Extension
  File "/tmp/tmpj6xtuc/obitools.zip/setuptools/extension.py", line 8, in <module>
  File "/tmp/tmpj6xtuc/obitools.zip/setuptools/dist.py", line 21, in <module>
AttributeError: 'module' object has no attribute 'packaging'

Storing debug log for failure in /home/hoekstra10/.pip/pip.log
Installing OBITools (1.1.22) in serenity mode


        ___
      ,'._,`.
     (-.___.-)
     (-.___.-)
     `-.___.-'
      ((  @ @|              .            __
       \   ` |         ,\   |`.    @|   |  |      _.-._
      __`.`=-=mm===mm:: |   | |`.   |   |  |    ,'=` '=`.
     (    `-'|:/  /:/  `/  @| | |   |, @| @|   /---)W(---\ 
      \ \   / /  / /         @| |   '         (----| |----) ,~
      |\ \ / /| / /            @|              \---| |---/  |
      | \ V /||/ /                              `.-| |-,'   |
      |  `-' |V /                                 \| |/    @'
      |    , |-'                                 __| |__
      |    .;: _,-.                         ,--""..| |..""--.
      ;;:::' "    )                        (`--::__|_|__::--')
    ,-"      _,  /                          \`--...___...--'/
   (    -:--'/  /                           /`--...___...--'\  
    "-._  `"'._/                           /`---...___...---'\  
        "-._   "---.                      (`---....___....---')
         .' ",._ ,' )                     |`---....___....---'|
         /`._|  `|  |                     (`---....___....---')
        (   \    |  /                      \`---...___...---'/
         `.  `,  ^""                        `:--...___...--;'
           `.,'               hh              `-._______.-'


/bin/sh: 1: /home/hoekstra10/Working_dir/Ipython-Notebooks/obitool/OBITools-1.1.22/bin/python: not found
Traceback (most recent call last):
  File "setup.py", line 37, in <module>
    serenity=serenity_mode(PACKAGE,VERSION)
  File "distutils.ext/obidistutils/serenity/__init__.py", line 109, in serenity_mode
    serenity_snake(args.virtual,package,version)
  File "distutils.ext/obidistutils/serenity/__init__.py", line 58, in serenity_snake
    virtualpython=serenity_virtualenv(envname,package,version,minversion=minversion)
  File "distutils.ext/obidistutils/serenity/virtual.py", line 105, in serenity_virtualenv
    ok = (is_good_python27(python) and 
  File "distutils.ext/obidistutils/serenity/checkpython.py", line 143, in is_good_python27
    rep = is_python27(path) and \
  File "distutils.ext/obidistutils/serenity/checkpython.py", line 41, in is_python27
    return     pythonversion >=StrictVersion("2.7") \
  File "/usr/lib/python2.7/distutils/version.py", line 140, in __cmp__
    compare = cmp(self.version, other.version)
AttributeError: StrictVersion instance has no attribute 'version'
Traceback (most recent call last):
  File "get-obitools.py", line 45234, in <module>
    main()
  File "get-obitools.py", line 45196, in main
    envactivate = open(os.path.join(virtualenvname,'bin','activate')).readlines()
IOError: [Errno 2] No such file or directory: '/home/hoekstra10/Working_dir/Ipython-Notebooks/obitool/OBITools-1.1.22/bin/activate'

Print this item

Sad problems with installing ecoPCR
Posted by: agnes.e - 06-24-2015, 01:10 PM - Forum: Installing OBITools - No Replies

I have problems with installing ecoPCR:
 -after downloading source there was no ecoPCR.tar.gz file only separate .gz files
 -libecoPCR folder seems not complete and make command couldn't run. It said:
 (...)' make[1]: Entering directory '/home/csicsi/Letöltések/trunk/src/libecoPCR'
../global.mk:18: ecoapat.P: No such file or directory
../global.mk:18: ecodna.P: No such file or directory
../global.mk:18: ecoError.P: No such file or directory
../global.mk:18: ecoIOUtils.P: No such file or directory
../global.mk:18: ecoMalloc.P: No such file or directory
../global.mk:18: ecorank.P: No such file or directory
../global.mk:18: ecoseq.P: No such file or directory
../global.mk:18: ecotax.P: No such file or directory
../global.mk:18: ecofilter.P: No such file or directory
../global.mk:18: econame.P: No such file or directory'(...)

Could anyone help me, please?

Print this item

  How to build a reference database - commands
Posted by: coissac - 06-05-2015, 10:10 AM - Forum: Bioinformatics practicals - No Replies

Raw command history from the practicals with Eric on how to setup a reference database from genbank or embl database

```
  168  obiconvert --skip-on-error --ecopcrdb-output=embl-vrt -d ncbi-2015-06-04 rel_std_vrt_01_r123.dat.gz
  169  ls -l
  170  ecoPCR -d embl-vrt -l 80 -L 120 -e 4 TTAGATACCCCACTATGC TAGAACAGGCTCCTCTAG > embl-vrt.e4.ecopcr
  171  less embl-vrt.e4.ecopcr
  172  obiconvert embl-vrt.e4.ecopcr | less
  173  obigrep -h  embl-vrt.e4.ecopcr
  174  obigrep --require-rank=species --require-rank=genus --require-rank=family -d embl-vrt  embl-vrt.e4.ecopcr > embl-vrt.goodtaxid.fasta
  175  obicount  embl-vrt.e4.ecopcr
  176  obicount  embl-vrt.goodtaxid.fasta
  177  obigrep --require-rank=species --require-rank=genus --require-rank=family -d embl-vrt  -v embl-vrt.e4.ecopcr | less
  178  obigrep -h
  179  obigrep -s '^[acgt]+$' embl-vrt.goodtaxid.fasta > embl-vrt.acgt.fasta
  180  obicount embl-vrt.acgt.fasta
  181  obicount  embl-vrt.goodtaxid.fasta
  182  obiannotate -k taxid embl-vrt.acgt.fasta > embl-vrt.taxid.fasta
  183  less embl-vrt.taxid.fasta
  184  obiannotate -h
  185  obiannotate --with-taxon-at-rank=species embl-vrt.taxid.fasta # embl-vrt.species.fasta
  186  obiannotate --with-taxon-at-rank=species embl-vrt.taxid.fasta > embl-vrt.species.fasta
  187  less embl-vrt.species.fasta
  188  obiannotate -d embl-vrt --with-taxon-at-rank=species embl-vrt.taxid.fasta > embl-vrt.species.fasta
  189  less embl-vrt.species.fasta
  190  obigrep -p 'species!=taxid' embl-vrt.species.fasta
  191  obigrep -p 'species!=taxid' embl-vrt.species.fasta | less
  192  obigrep -p 'species!=taxid' embl-vrt.species.fasta | obicount
  193  obiuniq -c species embl-vrt.species.fasta > embl-vrt.uniq.fasta
  194  obicount embl-vrt.uniq.fasta
  195  obistat -c count embl-vrt.uniq.fasta
  196  obistat -c count embl-vrt.uniq.fasta | sort -nk 1
  197  obigrep -p 'count==161' embl-vrt.uniq.fasta
  198  obiannotate -h
  199  obiannotate -A taxid -v  -S taxid:species embl-vrt.uniq.fasta # embl-vrt.ref.fasta
  200  obiannotate -A taxid -v  -S taxid:species embl-vrt.uniq.fasta > embl-vrt.ref.fasta
  201  gedit embl-vrt.ref.fasta
```

Print this item